Python 3 llega a Archlinux

Con las últimas actualizaciones de paquetes, Archlinux ha actualizado Python a la rama 3.x. Aún se mantiene la rama 2.x, en concreto la versión 2.7, pero con el nombre del binario python2.

Esto significa que todas las aplicaciones ahora utilizarán por defecto la nueva rama de este lenguaje de programación. Pero que no cunda el pánico, se han actualizado también todos los paquetes que dependían de Python para que no haya problemas. Eso sí, sed pacientes con los paquetes de AUR hasta que se actualicen todos los pkbuild.

Una vez más, Archlinux apostando por la última tecnología sin descuidar la estabilidad.

Archlinux | Python is now Python 3

Anuncios

8 Responses to “Python 3 llega a Archlinux”


  1. 1 Hector octubre 20, 2010 en 2:00 am

    Terrible

  2. 2 Ravenman octubre 20, 2010 en 9:06 pm

    Me encanta el software libre y lo apoyo cuanto me es posible, pero realmente me empieza a molestar que se actualice Firefox y el xulrunner … y el IceCat quede como la cenicienta de la casa.

    No he podido instalarme el IceCat desde el AUR, porque me da un error con el python. Se agradecen ideas.

    • 3 iyanmv octubre 20, 2010 en 9:23 pm

      edita el pkbuild y cambia python por python2.

      Un saludo!

      • 4 Ravenman octubre 20, 2010 en 10:04 pm

        Gracias por el interés, pero parece que no es tan sencillo:

        checking for full perl installation… yes
        checking for python2.5… no
        checking for python2.4… no
        checking for python… no
        configure: error: python was not found in $PATH
        *** Fix above errors and then restart with “make -f client.mk build”
        make[1]: *** [configure] Error 1
        make[1]: Leaving directory `/tmp/yaourt-tmp-root/aur-icecat/src/icecat-3.6.10′
        make: *** [/tmp/yaourt-tmp-root/aur-icecat/src/icecat-3.6.10/Makefile] Error 2
        Aborting…
        ==> ERROR: Makepkg was unable to build icecat.

        En los comentarios (http://aur.archlinux.org/packages.php?ID=14169), Wonder indica sobre el uso de un parche, pero no sé cómo hacerlo. :-s

  3. 5 iyanmv octubre 20, 2010 en 11:46 pm

    Ok. Mañana miro y te comento. Ahora no puedo que estoy agotado y me voy a dormir… jaja

    Un saludo!

    • 6 Ravenman octubre 21, 2010 en 1:09 am

      Dicen que la intención es lo que vale. Gracias por el interés. Figue actualizó el paquete y ya tengo activo Icecat en mi Arch Linux otra vez.

  4. 7 MerolWarrior febrero 19, 2011 en 7:44 am

    Por esa misma razón aun no eh podido instalar Gwibber (y casi ningún empaquetado de Yaourt 😦 )


  1. 1 Bitacoras.com Trackback en octubre 19, 2010 en 5:31 pm

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s




Fedora 14

Visitas al blog

  • 699,080 visitas

Bienvenido!!

Estimado lector, en primer lugar, gracias por seguir mi blog y ayudar a mejorarlo. En esta bitácora encontrarás noticias, tutoriales y muchas cosas más sobre GNU/Linux y el Software Libre, sobre todo de dos distribuciones, Fedora y Arch Linux. No dudes en preguntar tus dudas, comentar las entradas o proponerme ideas para el blog. Más información en Acerca de
Creative Commons License
Esta obra está bajo una licencia de Creative Commons.

Introduce tu correo para suscribirte a este blog y recibir las entradas en tu correo.

Únete a otros 72 seguidores

Comentarios recientes

Marcos en Post-Instalación de Arch …
Dasn en NTP en ArchLinux
Maria en Borrón y cuenta nueva
iyan gonzalez en Borrón y cuenta nueva
Spanish Red en Fedora o Archlinux

Guia de Usuario Fedora 14

Post-instalación de Arch Linux

Categorías

Fedora Blogger Network


A %d blogueros les gusta esto: