Volver a KDE SC 4.4.5 en Archlinux. ¿Posible?

Varias personas me han estado preguntado si es posible volver a la anterior rama de KDE SC, es decir a la versión 4.4.5. En una distribución rolling release como es Archlinux esto es un poco complicado pero con un poco de paciencia (y suerte) podemos hacerlo.

En el siguiente post os explicaré cómo realizar un downgrade del entorno gráfico KDE SC de dos formas. Una es sencilla y rápida, pero para ello tenemos que conservar en el disco duro los paquetes de KDE SC 4.4.5. En concreto en la cache de pacman, que se encuentra en /var/cache/pacman/pkg. La otra es más compleja y dependemos de los llamados Out-Of-Sync Mirrors, que son unos mirrors especiales que no se mantienen actualizados sino que mantienen versiones obsoletas de los paquetes a proposito.

Antes de empezar recomiendo seguir este tutorial sólamente a aquellos que tengan muchos problemas con KDE SC 4.5.2. Es decir usuarios de tarjetas gráficas Intel sobre todo o también ATI que tengan un entorno inestable por culpa de los efectos de escritorio. También os aviso de que puede que en algunos casos no sea posible este downgrade. Si estás seguro de lo que haces y quieres arriesgarte puedes continuar. 🙂

Downgrade a KDE SC 4.4.5 (Opción A)

Requisitos:

  • Conservar los paquetes de KDE SC 4.4.5 en el disco duro. Si no has hecho un sudo pacman -Scc recientemente seguramente aún los tengas.

Si cumples esta condición arranca una terminal y logueate como root. A continuación accede al directorio de la cache de pacman:

su -
cd /var/cache/pacman/pkg

Por último instalamos todos los paquetes de KDE en esta versión con el siguiente comando:

pacman -U kde*4.4.5*.pkg.tar.gz

Si tenemos un poco de suerte ya estará. Si tenemos algún problema porque faltan algunas dependencias entonces probaremos con la opción B. Antes de reiniciar os recomiendo que mováis la carpeta de configuración de KDE a otro sitio para evitar conflictos. Abrimos de nuevo la terminal (esta vez, con tu usuario):

mv ~/.kde4 ~/.kde4-bak

Downgrade a KDE SC 4.4.5 (Opción B)

Esta opción consiste en utilizar un mirror desactualizado y volver a descargar e instalar KDE SC 4.4.5. Es más complicado que la otra opción porque dependemos de mirrors poco mantenidos y, en general, con muy pocos usuarios. En la wiki de Archlinux podemos encontrar varios mirrors de este tipo, pero actualmente sólo funciona uno. De todas formas buscando un poco por google encontré uno que mantiene todos los paquetes de la rama 4.4.5. Justo lo que necesitamos.

Para añadirlo abrimos una terminal y escribimos:

sudo nano /etc/pacman.d/mirrorlist

Arriba del todo, en la primera línea por ejemplo, añadimos lo siguiente:

Server = ftp://mirror.cs.vt.edu/pub/ArchLinux/$repo/os/$arch

Ahora actualizamos las bases de datos locales:

sudo pacman -Syy

E instalamos KDE de nuevo:

sudo pacman -S kde kde-l10n-es

Si todo va bien, tendremos de nuevo KDE SC 4.4.5 en nuestro sistema. Al igual que en la Opción A, antes de reiniciar os recomiendo que mováis la carpeta de configuración de KDE a otro sitio para evitar conflictos. Abrimos de nuevo  la terminal (con tu usuario):

mv ~/.kde4 ~/.kde4-bak

Evitar actualizar de nuevo a KDE SC 4.5.x

Este último paso tenéis que realizarlo todos los que hayáis realizado con éxito el downgrade, ya sea por método A o B. Se trata de añadir KDE a la lista de grupos a ignorar pacman. ¿Por qué hacer esto? Pues para volver a utilizar mirrors actualizados sin que se nos actualice el entorno gráfico a la última versión estable. Para ello abrimos una terminal (la última vez, os lo prometo) y escribimos:

sudo nano /etc/pacman.conf

Buscamos la línea que pone IgnoreGroup y la dejamos de esta forma (acordaros de borrar el # inicial):

IgnoreGroup = kde-l10n kde-meta kde kdeaccessibility kdeadmin kdeartwork kdebase kdeedu kdegames kdegraphics kdemultimedia kdenetwork kdepim kdeplasma-addons kdesdk kdetoys kdeutils kdewebdev

ArchWiki | Out-of-sync mirrors

Anuncios

15 Responses to “Volver a KDE SC 4.4.5 en Archlinux. ¿Posible?”


  1. 1 Camilo Guzman rios octubre 6, 2010 en 10:23 pm

    Bueno iyan y de ahi en adelante como se haria para mataner el sistema al dia? y para los programas en general todo? sin alterar el kde sc 4.4.5

    • 2 iyanmv octubre 6, 2010 en 10:31 pm

      ya actualicé la entrada. 🙂 Se me había olvidado comentar eso.

      Un saludo!

  2. 3 Camilo Guzman rios octubre 6, 2010 en 10:44 pm

    q pena tanta preguntadera pero eres el guru de arch+kde 😉 una perguntica mas y listo referente a programas no habria problemas? me refiero a programas como tal de kde q me imagino q ya estan actulizados para funcionar con kde sc 4.5 o no se como se maneja eso.

    Gracias..

  3. 4 Jestern octubre 6, 2010 en 11:01 pm

    Buenas iyan, es muy util tener esta info, me hubiese sido util cuando actualicé a 4.5.0, ahora no tengo problemas.
    Solo un par de detalles, que conste que no lo he probado, al hacer “sudo pacman -S kde” lo que hace es instalar toda la suit de KDE (Edu , network, etc) para los que usan una instalacion mínima puede ser un problema XD lo que no sabia es que se pueden añadir repositorios sin el nombre XD

    Saludos y enhorabuena por el blog 😛

  4. 5 iyanmv octubre 6, 2010 en 11:07 pm

    @Camilo Guzman rios En principio no tendría que haber problemas, ya que se adaptan a KDE SC 4.5 pero siguen mantiendo soporte para KDE SC 4.x. Por ejemplo, Amarok funciona perfectamente en KDE SC 4.5 como en KDE SC 4.4.

    @Jestern puse instalar el entorno entero para no tener problemas con no downgradear algún paquete. Por supuesto puedes ir haciendo esto con cada paquete pero se hace un poco pesado.
    A qué te refieres con el nombre del server? xD

  5. 6 Jestern octubre 7, 2010 en 12:06 am

    @iyanmv A mi cuando me equivoco en por ejemplo [archlinuxfr] y pongo otra cosa no me coge el repositorio pacman XD

  6. 7 totoloco octubre 7, 2010 en 12:53 am

    Muy buena data para el downgrade 😀
    Aunque por ahora sigo con arch + kde 4.5.2
    salU

  7. 8 camilo guzman rios octubre 7, 2010 en 3:26 am

    bueno me alcance a ilusionar por que: hice una instalacion limpia de arch y pues la logre con repo de canada dado q el pone iyan no funciona, inicia todo bien perfecto como es el 4.4.5 pero al momento de cambiar el repo por obvias razones pero hay cosas q todavia pide actulizar de kde 4.5.2 y pues al momento de verificar e instalar bota error pero salen como 4 o 5 cositas para actualizar. hice lo q dice el amigo iyan de agregar a pacman.conf (IgnoreGroup = kde) pero nose faltaria algo mas para agregar para q asi no busque nada referente a kde? espero puedas ayudarnos un pco mas amigo iyan

    • 9 iyanmv octubre 7, 2010 en 8:33 am

      tenías razón. Nunca utilicé esta función de pacman y di por hecho que añadiendo kde como grupo ignoraría todos los paquetes de kde pero no es así. Revisa otra vez el final del post, que lo actualicé para que no tengas problemas.

      Un saludo!

      PD: gracias por ser el “tester” del post xD

  8. 10 Midou octubre 7, 2010 en 2:54 pm

    En serio KDE 4.5 es tan malo para que valga la pena hacer un downgrade??, yo tengo algunos Bugs y los efectos de escritorio desactivados, pero pues, así puedo vivir xD

    • 11 iyanmv octubre 7, 2010 en 10:50 pm

      Por supuesto que no. KDE SC 4.5.2 es ya una versión muy estable y con muchas novedades de las que kde sc 4.4.x no dispone. El problema es que los efectos de KWin no funcionan bien con las tarjetas ATI e Intel. Por lo demás funciona perfectamente como tú dices.
      Yo estoy encantado con esta versión 🙂

      Un saludo!

  9. 12 Camilo Guzman rios octubre 10, 2010 en 1:35 am

    una pregunta curiosa: el problema de kde sc 4.5 con las tarjetas intel es por q? la version del driver o la version de opengl? si fuese por cualquiera no se puede cambiar de driver a una version antigua aver si funciona?


  1. 1 Bitacoras.com Trackback en octubre 6, 2010 en 10:04 pm
  2. 2 Have no pacman ? No problem | Money From Traffic Trackback en octubre 7, 2010 en 12:56 am
  3. 3 BlogESfera.com Trackback en octubre 7, 2010 en 2:09 am

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s




Fedora 14

Visitas al blog

  • 699,713 visitas

Bienvenido!!

Estimado lector, en primer lugar, gracias por seguir mi blog y ayudar a mejorarlo. En esta bitácora encontrarás noticias, tutoriales y muchas cosas más sobre GNU/Linux y el Software Libre, sobre todo de dos distribuciones, Fedora y Arch Linux. No dudes en preguntar tus dudas, comentar las entradas o proponerme ideas para el blog. Más información en Acerca de
Creative Commons License
Esta obra está bajo una licencia de Creative Commons.

Introduce tu correo para suscribirte a este blog y recibir las entradas en tu correo.

Únete a otros 72 seguidores

Comentarios recientes

Marcos en Post-Instalación de Arch …
Dasn en NTP en ArchLinux
Maria en Borrón y cuenta nueva
iyan gonzalez en Borrón y cuenta nueva
Spanish Red en Fedora o Archlinux

Guia de Usuario Fedora 14

Post-instalación de Arch Linux

Categorías

Fedora Blogger Network


A %d blogueros les gusta esto: